BrianBezanson

Issue in the pom.xml generated for the plug-in step

Discussion created by BrianBezanson on Aug 17, 2015
Latest reply on Aug 26, 2015 by Ryan King

Updates 2015-08-19:

 

Note: The plugin/pom.xml generated by the command:

mvn -U jive:create-plugin


Generates an error about the need for a "version". But the reality is an outdated artifactId was used (pre javax definition).


The plug-in generated pom.xml should be defined as shown below - based on the property defined in the jive parent pom.xml.


<dependency>
  <groupId>javax.servlet</groupId>
  <artifactId>${servlet.api.artifactId}</artifactId>
</dependency>

Outcomes